Issue
Old MobileTech batches keep appearing in the Payroll system. Sometimes these batches have transactions and sometimes they do not. If you delete the batches they reappear.
Cause
This situation is caused by old/bad data on a MobileTech users’ device. When the user runs a Sync in MobileTech the old/bad data is sent to the payroll system. The system creates the batch and then may create the old Payroll transactions. On the device the transaction is not marked complete because of some error. Because the transaction is not marked complete the system will keep sending the transaction each time the user runs a Sync. This then recreates the old batch. This circle will keep happening until the old/bad data is removed from the users MobileTech device.
Solution
To fix this the old/bad data needs to be removed from the users MobileTech device and then the batch needs to be deleted from Payroll.
To accomplish this the user and Payroll must coordinate the following actions in order
- User needs to run a Sync in MobileTech
- This will make sure any good data on the device has been sent to the server.
- User needs to delete data in MobileTech
- This is located on the “Setup” tab in MobileTech.
- This will remove all data from the device including the old/bad data.
- User needs to run a Sync in MobileTech
- This will reload all the good data from the server, but it will not reload the old/bad data
- Payroll needs to delete the old batch
- This will remove the batch. It should not come back now that the old/bad data has been removed from the user’s device.